This project is read-only.

SimpleLucene is not compatible with Lucene.net 3.0.3

Nov 5, 2012 at 3:05 PM
Edited Nov 5, 2012 at 3:06 PM

Because of using Lucene.net heightlight feature i updated my Lucene.net library from 2.9.4.1 to 3.0.3 and after that I'm getting this error when I try to use add query method .

Could not load type 'Occur' from assembly 'Lucene.Net, Version=3.0.3.0, Culture=neutral, PublicKeyToken=85089178b9ac3181'.


after checking some online solutions such as removing asp.net temp files or checking GAC i found that actually there is a compatibility problem . I removed Lucene.net 3.0.3 from project and reinstalled 2.9.4.1 and every things works perfectly with this version .